站长资讯网
最全最丰富的资讯网站

phpMyAdmin.conf中的内容是什么意思

下面由phpmyadmin教程栏目给大家介绍有关linux下的phpmyadmin的配置文件,希望对需要的朋友有所帮助!

发现问题:

linux下的phpmyadmin的配置文件

Alias /phpMyAdmin /usr/share/phpMyAdminAlias /phpmyadmin /usr/share/phpMyAdmin<Directory /usr/share/phpMyAdmin/>    <IfModule mod_authz_core.c>      # Apache 2.4      <RequireAny>        Require ip 127.0.0.1        Require ip ::1      </RequireAny>    </IfModule>    <IfModule !mod_authz_core.c>      # Apache 2.2      Order Deny,Allow      Deny from All      Allow from 127.0.0.1      Allow from ::1    </IfModule></Directory>

我的Apache版本是2.4的,以上是/etc/httpd/conf.d/phpMyAdmin.conf里面的一段内容,并不十分明白其中的具体意思,求解释一下。

解释如下:

# 虚拟目录 http://localhost/phpMyAdmin 指向 /usr/share/phpMyAdmin Alias /phpMyAdmin /usr/share/phpMyAdmin # 虚拟目录 http://localhost/phpmyadmin 指向 /usr/share/phpMyAdmin Alias /phpmyadmin /usr/share/phpMyAdmin # 目录相关设置 <Directory /usr/share/phpMyAdmin/>    # mod_authz_core.c 是 apache 2.3 之后新增的权限验证模块    # 在这里用判断这个模块是否存在的方法区分 apache 版本    # 如果存在说明当前 apache 版本至少是 2.3    <IfModule mod_authz_core.c>      # 下面一行注释表明这里在 apache 版本是 2.4 的时候会执行      # Apache 2.4       # 新式的权限控制写法 满足以下任一条件才能访问      <RequireAny>        # 用户的请求 IP 是本机 ( IPv4 )        Require ip 127.0.0.1        # 用户的请求 IP 是本机 ( IPv6 )        Require ip ::1      # 权限控制区块结束      </RequireAny>    # 模块判断区块结束    </IfModule>    # 如果不存在 mod_authz_core.c 说明当前 apache 版本低于 2.3    <IfModule !mod_authz_core.c>      # 下面一行注释表明这里在 apache 版本是 2.2 的时候会执行      # Apache 2.2      # mod_authz_host 提供旧式的权限控制写法 Deny 在前表示白名单模式       Order Deny,Allow      # 禁止除去下面 Allow 之外的所有请求      Deny from All      # 允许本地访问 ( IPv4 )      Allow from 127.0.0.1      # 允许本地访问 ( IPv6 )      Allow from ::1    # 模块判断区块结束    </IfModule> # 目录设置区块结束 </Directory>

再有这不是 phpMyAdmin 的配置文件 … 这是 Apache 的 …

赞(0)
分享到: 更多 (0)