当前位置: 主页 > 网络知识 > CISCO技术 > cisco 3560端口限速配置

cisco 3560端口限速配置

时间:2009-11-16来源:互联网 点击:
Cisco3560 交换机端口限速配置
(4.1)、网络说明
 PC1接在Cisco3560 F0/1上,速率为1M;
 PC1接在Cisco3560 F0/2上,速率为2M;
 Cisco3560的G0/1为出口。
(4.2)详细配置过程
注:每个接口每个方向只支持一个策略;一个策略可以用于多个接口。因此所有PC的下载速率的限制都应该定义在同一个策 略(在本例子当中为policy-map user-down),而PC不同速率的区分是在Class-map分别定义。
from:http://networkcommand.org/cisco/catalyst-3560/cisco-3560-configuration-example
  a、在交换机上启动QOS

  Switch(config)#mls qos //在交换机上启动QOS

  b、分别定义PC1(10.10.1.1)和PC2(10.10.2.1)访问控制列表

  Switch(config)#access-list 10 permit 10.10.1.0 0.0.0.255 //控制pc1上行流量

  Switch(config)#access-list 100 permit any 10.10.1.0 0.0.0.255 //控制pc1下行流量

  Switch(config)#access-list 11 permit 10.10.2.0 0.0.0.255 //控制pc2上行流量

  Switch(config)#access-list 111 permit any 10.10.2.0 0.0.0.255 //控制pc2下行流量

  c、定义类,并和上面定义的访问控制列表绑定

  Switch(config)# class-map user1-up //定义PC1上行的类,并绑定访问列表10

  Switch(config-cmap)# match access-group 10

  Switch(config-cmap)# exit

  Switch(config)# class-map user2-up

  Switch(config-cmap)# match access-group 11 //定义PC2上行的类,并绑定访问列表10

  Switch(config-cmap)# exit

  Switch(config)# class-map user1-down

  Switch(config-cmap)# match access-group 100 //定义PC1下行的类,并绑定访问列表100

  Switch(config-cmap)# exit

  Switch(config)# class-map user2-down

  Switch(config-cmap)# match access-group 111 //定义PC2下行的类,并绑定访问列表111

  Switch(config-cmap)# exit

  d、定义策略,把上面定义的类绑定到该策略

  Switch(config)# policy-map user1-up //定义PC1上行的速率为1M

  Switch(config-pmap)# class user1-up

  Switch(config-pmap-c)# trust dscp

  Switch(config-pmap-c)# police 1024000 1024000 exceed-action drop

  Switch(config)# policy-map user2-up //定义PC2上行的速率为2M

  Switch(config-pmap)# class user2-up

  Switch(config-pmap-c)# trust dscp

  Switch(config-pmap-c)# police 2048000 1024000 exceed-action drop

  Switch(config)# policy-map user-down

  Switch(config-pmap)# class user1-down

  Switch(config-pmap-c)# trust dscp

  Switch(config-pmap-c)# police 1024000 1024000 exceed-action drop

  Switch(config-pmap-c)# exit

  Switch(config-pmap)# class user2-down

  Switch(config-pmap-c)# trust dscp

  Switch(config-pmap-c)# police 2048000 1024000 exceed-action drop

  Switch(config-pmap-c)# exit

  e、在接口上运用策略

  Switch(config)# interface f0/1

  Switch(config-if)# service-policy input user1-up

  Switch(config)# interface f0/2

  Switch(config-if)# service-policy input user2-up

  Switch(config)# interface g0/1
 Switch(config-if)# service-policy input user-down
站长资讯网
. TAG: CISCO 端口 限速

查看[cisco 3560端口限速配置]所有评论
发表评论
请自觉遵守互联网相关的政策法规,严禁发布色情、暴力、反动的言论。
用户名: 验证码:
推荐内容最近更新人气排行
关于我们 | 友情链接 | 网址推荐 | 常用资讯 | 网站地图 | RSS | 网站留言